1. <menuitem id="f3it7"></menuitem>
      <menuitem id="f3it7"><strong id="f3it7"></strong></menuitem>
      <samp id="f3it7"></samp>

      <progress id="f3it7"><nobr id="f3it7"></nobr></progress>

              第十五天实验---VLAN实验

            最后更新:5个月前 手机定位技术交流文章

            PC1和PC3是访问接口,并且都是VLAN2,因此剩下的主机不是同一网络段,并且通过一个子接口实现。

            2,PC2/4/5/6是同一个网络段,并有权设置限制,所以接口类型可以在混合模式中实现。

            所有交换机之间的交通必须通过,所以设置其接口类型为总线模式,允许所有VLAN通过。

            4.在SW1连接器接口上标记VLAN2流量,标记旋转子接口,并无标记将剩余的流量设置到物理接口。

            总体配置思路:

            1 LSW1 - 在LSW3上创建一个VLAN。

            2,PC1PC3端口是访问模式,pvlan是VLAN2.

            其他PC的连接器处于混合模式,而PC4/5不能访问6,所以4.5允许列表中的设置不允许6通,而6上的设置不允许4.5通。

            交换机之间的接口,设置为总线模式,允许所有VLAN通过

            开关与路由器之间的接口设置为混合模式,VLAN2流量设置为标签。

            6.配置 DHCP地址池以允许它分配IP地址。

            配置步骤:

            ●LSW1配置:

            创建VLAN2 – VLAN5

            [SW1]vlan batch 2 to 5

            PC1连接端口:用于访问模式,属于VLAN2

            interface GigabitEthernet0/0/2

            port link-type access

            port default vlan 2

            PC2所连接端口:为hybrid(混杂)模式,打标签为VLAN3,设置所有流量进入不打标签

            interface GigabitEthernet0/0/3

            port hybrid pvid vlan 3

            port hybrid untagged vlan 3 to 5

            ●LsW1和LsW2之间的端口:用于总线模式,设置允许所有VLAN流量通过

            interface GigabitEthernet0/0/1

            port link-type trunk

            port trunk allow-pass vlan 2 to 4094

            ●LSW2配置:

            创建VLAN2 – VLAN5

            [SW1]vlan batch 2 to 5

            PC3连接端口:用于访问模式,属于VLAN2

            interface GigabitEthernet0/0/3

            port link-type access

            port default vlan 2

            PC4所连接端口:为hybrid(混杂)模式,打标签VLAN4,设置VLAN3/4流量进入不打标签,让VLAN5流量不在允许列表里面。

            interface GigabitEthernet0/0/4

            port hybrid pvid vlan 4

            port hybrid untagged vlan 3 to 4

            LSW2 和 LSW1 和 LSW2 和 LSW3: 接口处于总线模式,允许它通过所有VLAN流量

            interface GigabitEthernet0/0/1

            port link-type trunk

            port trunk allow-pass vlan 2 to 4094

            ●LSW3配置:

            创建VLAN2 – VLAN5

            [SW1]vlan batch 2 to 5

            PC5连接端口:键入VLAN4,设置VLAN3/4流量为非标记,并让VLAN5流量不被允许在列表中。

            interface GigabitEthernet0/0/2

            port hybrid pvid vlan 4

            port hybrid untagged vlan 3 to 4

            PC6连接端口:键入VLAN4,设置VLAN3/5流量为非标记,并让VLAN4流量不被允许在列表中。

            interface GigabitEthernet0/0/3

            port hybrid pvid vlan 5

            port hybrid untagged vlan 3 5

            完成上述基本配置后,VLAN路间配置

            1.在路由器上配置一个子接口,让子接口属于VLAN2.

            2、路由器子接口流量要去VLAN2,需要携带标签,所以VLAN2中的PC去往子接口也是需要携带标签的。

            3.进入VLAN 3/4/5流量,路由器物理接口上的流量没有标签,但是由于开关接口默认为pvid是1,所以,当它从路由器端口输入开关时,这个非标记流量被标记为VLAN1流量。同时,由于三种接口模式都默认允许VLAN1传输,因此,这个流量部分可以到达相应的VLAN PC。

            ●切换连接路由器端口:

            #设置继续携带VLAN2标签,而不是VLAN 3/4/5标签

            interface GigabitEthernet0/0/4

            port hybrid tagged vlan 2

            port hybrid untagged vlan 3 to 5

            最后, 配置路由器:

            <1>、开启DHCP地址池

            dhcp enable

            <2>、创建两个地址池

            #为VLAN2创建地址池:

            ip pool vlan2

            gateway-list 172.16.1.254

            network 172.16.1.0 mask 255.255.255.0

            dns-list 114.114.114.114

            #为VLAN 3/4/5/创建地址池

            ip pool vlan

            gateway-list 172.16.2.254

            network 172.16.2.0 mask 255.255.255.0

            dns-list 8.8.8.8

            ●子接口配置:

            interface GigabitEthernet0/0/0.1

            dot1q termination vid 2? --->标记为VLAN2流量

            ip address 172.16.1.254 255.255.255.0

            arp broadcast enable??? ------>记得开启arp广播机制

            dhcp select global

            物理接口配置:

            interface GigabitEthernet0/0/0

            ip address 172.16.2.254 255.255.255.0

            dhcp select global

            本文由 在线网速测试 整理编辑,转载请注明出处,原文链接:http://www.coffschurch.com/news/31035.html

                热门文章

                文章分类

            乱H高H公车
            1. <menuitem id="f3it7"></menuitem>
              <menuitem id="f3it7"><strong id="f3it7"></strong></menuitem>
              <samp id="f3it7"></samp>

              <progress id="f3it7"><nobr id="f3it7"></nobr></progress>